Account and Billing page timeouts due to payment processor maintenance
Incident Report for Bitrise CI
Resolved
This incident has been resolved.
Posted Sep 18, 2017 - 14:51 UTC
Monitoring
Our payment processor service completed their maintenance, we're still monitoring the system.
Posted Sep 18, 2017 - 14:30 UTC
Identified
Due to an ongoing maintenance on our payment processor billing and account related pages might experience timeouts.
Posted Sep 18, 2017 - 13:52 UTC