Hanging Linux builds

Incident Report for Bitrise CI

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 13:47 UTC

Update

A new Linux stack update was deployed with a kernel upgrade that should address this. We believe this is the root cause of the hanging builds, and affected projects should run test builds on the latest stack version. Let us know if you have feedback or further problems at support@bitrise.io.
Posted Apr 28, 2025 - 09:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2025 - 09:04 UTC

Identified

We are still collecting data, but this issue only affects a small percentage of users.
We are also planning fixes and are working on confirming them.

In the meantime, if you experience this issue you can roll back the stack you are using: https://devcenter.bitrise.io/en/infrastructure/build-stacks/stack-update-policy.html#using-the-previous-version-of-a-stack

In case the rollback channel doesn’t solve the issue, please reach out us and we'll take a closer look.
Posted Apr 25, 2025 - 15:28 UTC

Investigating

We are investigating hanging steps and workflows for a small percentage of Linux builds
Posted Apr 25, 2025 - 07:58 UTC
This incident affected: Build Processing (Linux Stack (Android, web projects, ...)).