This incident is now resolved and impacted services are now operating without issues.
Our teams identified the root cause, released a fix and were monitoring our systems continuously to ensure the mitigation is safe. We'll conduct an internal post-mortem to understand what happened and learn how to avoid a similar outage in the future.
Thank you for your patience and understanding. If you encounter any issues, please reach out to our Support team:
we have released a fix for the Gradle plugin portal not being found in the "Install missing Android SDK components" step, and will continue monitoring
Services: Android builds
Scope: A subset of users
Severity: SEV-2
What we’re doing
We are actively monitoring our systems.
When will the next update be available?
You can expect a status update approximately 1 hour from now.
Posted Apr 28, 2026 - 19:29 UTC
Update
We have identified an issue with plugins on the Gradle plugin portal not being found in the Install missing Android SDK components step. We're releasing a fix
Posted Apr 28, 2026 - 18:52 UTC
Update
We're seeing build failures for customers who do not have the "Install missing Android SDK components" step added. We strongly suggest adding this step for mitigation to your workflow.
You can expect a status update approximately 1 hour from now.
Posted Apr 28, 2026 - 18:01 UTC
Monitoring
We mitigated this incident and are currently monitoring our systems to resolve
Services: Android Builds
Scope: A subset of users
Severity: SEV-1
What we’re doing
Our Engineering teams released a fix to mitigate this incident. We expect new builds to start, and we continue to monitor the situation.
When will the next update be available?
You can expect a status update approximately 1 hour from now.
Posted Apr 28, 2026 - 17:25 UTC
Identified
We are working on redirections to mitigate the current issue.
Services: Android Builds
Scope: A subset of users
Severity: SEV-2
What we’re doing?
Our Engineering teams identified the root cause and are now actively working on mitigations to restore stability across all affected services. We will perform validated mitigations as soon as they are determined safe.
When will the next update be available?
You can expect a status update approximately 1 hour from now.
Posted Apr 28, 2026 - 16:38 UTC
Investigating
We are currently investigating elevated errors for Android builds.
Services impacted: Android builds are failing due to MavenCentral request throttling
Scope: A subset of users
Severity: SEV-2
What we’re doing?
Our Engineering teams are actively investigating this incident, monitoring alerts, and tracing requests to identify the root cause. We will perform validated mitigations as soon as they are determined safe.
When will the next update be available?
You can expect a status update approximately 1 hour from now.