Elevated error rates on build details page

Incident Report for Bitrise

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 17:27 UTC

Monitoring

We mitigated this incident and are currently monitoring our systems to resolve HTTP errors, intermittent page load failures, or timeouts when accessing the site.

Services:
Build details pages on app.bitrise.io are failing to load.

Scope:
Subset of users

Severity:
SEV-1

What we’re doing

Our Engineering teams released a fix to mitigate this incident and are now actively monitoring our systems.

When will the next update be available?

You can expect a status update approximately 1 hour from now.
Posted Apr 28, 2026 - 12:29 UTC
This incident affected: ⚙️ Builds (CI).