Android - dependency download - 500 internal error issue - jcenter.bintray.com
Incident Report for Bitrise CI
Resolved
No errors for a while now, and download speeds from jcenter.bintray.com also seem to improve and are now around the usual numbers. Build Cache is still advised to protect against similar events in the future and to improve the android dependency download speed in general.
Posted over 1 year ago. Jun 20, 2017 - 20:12 UTC
Monitoring
The bintray issue is resolved now and we don't see errors anymore, but download speeds are still slower than usual. The previously mentioned Build Cache can help with that, and we're still monitoring the system.
Posted over 1 year ago. Jun 20, 2017 - 17:08 UTC
Identified
jcenter.bintray.com has issues right now, similar to the previous ones. You can find the related bintray issue at: http://status.bintray.com/incidents/v4ghm1s1xrp9

The error looks like:

```
> Could not resolve org.apache.httpcomponents:httpclient:4.1.1.
> Could not get resource 'https://jcenter.bintray.com/org/apache/httpcomponents/httpclient/4.1.1/httpclient-4.1.1.pom'.
> Could not GET 'https://jcenter.bintray.com/org/apache/httpcomponents/httpclient/4.1.1/httpclient-4.1.1.pom'. Received status code 500 from server: Internal Server Error
```

A simple and reliable mitigation can be to configure a Bitrise Build Cache for your Android project, so that your dependencies are cached and doesn't have to be downloaded from bintray. You can find a guide for the setup at: https://discuss.bitrise.io/t/how-to-cache-gradle-dependencies/194
Posted over 1 year ago. Jun 20, 2017 - 14:04 UTC