Unable to update GitHub Checks Statuses
Incident Report for Bitrise CI
Resolved
This incident has been resolved.
Posted Jul 12, 2023 - 18:42 UTC
Update
The root cause has been mitigated on our side but we are continuing to monitor the situation.

For some period of time, GitHubCheck results were not reported to GitHub. Users should find pipelines (e.g. filtering for Pull Requests and commit messages) and check the status manually – then force merge the PR on GitHub (If the corresponding pipeline is green).
Alternatively, rebuild pipelines. New pipeline runs should be good now. Old PRs with still missing checks are unlikely to recover.
Posted Jul 12, 2023 - 17:56 UTC
Monitoring
We have deployed a fix and are seeing progress. We are still monitoring the situation the results to be sure. We expect new pipelines to be running correctly and the system is retrying old messages. So it's likely that you will see statuses appearing on previous pipelines as well.
Posted Jul 12, 2023 - 15:06 UTC
Investigating
We are currently investigating this issue.
Posted Jul 12, 2023 - 11:11 UTC
This incident affected: Web App.