Issues with 2FA enabled Apple Developer accounts
Incident Report for Bitrise CI
Resolved
After in-depth research conducted by our tooling team we couldn't find a permanent solution to the ongoing issue with the 2FA enabled Apple Developer Accounts.
To summarise the issue: currently the session provided for 2FA Apple Developer Accounts is only kept alive for about 8 hours (this means that you have to re-authenticate on your profile page every 8 hours)

We are still looking for solutions that could help with authentication and we are also keeping an eye on Apple's announcements to be able to implement a new solution as soon as it is available.

In the meantime there are some workarounds for the issue:
- If you'd like to use the connected Apple Developer Account you'd need to login every 8 hours on your profile page on Bitrise.
- You can use the "Certificate and Profile Installer" step until there's a permanent solution (you can use our codesigndoc tool to export all the needed profiles and certificates - Paste this script into your terminal and follow the instructions bash -l -c "$(curl -sfL https://raw.githubusercontent.com/bitrise-tools/codesigndoc/master/_scripts/install_wrap.sh)" )
Posted 4 days ago. Dec 12, 2018 - 15:46 UTC
Update
With the workaround currently in place the Developer Portal session is kept alive only for a couple of hours and after that you have to re-authenticate your account.

Our team is currently looking into multiple ways to keep the session alive for a longer period of time.
Posted 9 days ago. Dec 07, 2018 - 10:30 UTC
Update
We deployed a temporary workaround for the issue.

If you still see the issue happening please unlink your Apple Developer Account and connect it again. You will be prompted to enter the 2FA code when you link the account, for the first time enter the code. If you'd visit the page again you'll be prompted to enter a code again, but you can simply ignore this prompt. We are working on fixing this UI issue.

Also please make sure you update your ios-auto-provision step to the latest version (version 1.2.2)!
Posted 10 days ago. Dec 06, 2018 - 19:32 UTC
Identified
We are currently seeing issues with the connection of 2FA enabled Apple Developer accounts caused by a changed authentication process on Apple Developer Portal. We are currently working on updating the authentication method we use to solve the issue.

A workaround until the issue is solved to use the Certificate and Profile Installer step with uploading the previously generated provisioning profiles on the Code Signing tab of the Workflow Editor
OR
Another workaround could be to temporarily disable 2FA on the Developer Portal Account or use an account that hasn't got 2FA enabled
Posted 10 days ago. Dec 06, 2018 - 14:27 UTC
This incident affected: Web App.