Users might experience issues with Gradle builds with build cache enabled

Incident Report for Bitrise CI

Resolved

This incident has been resolved.
Posted 14 days ago. Jun 12, 2025 - 09:00 UTC

Monitoring

We made a change in the Activate Bitrise Build Cache for Gradle step, and in the Bitrise Build Cache CLI, and re-enabled the Bitrise Build Cache for Gradle plugins. We're monitoring the system.
Posted 15 days ago. Jun 11, 2025 - 16:05 UTC

Update

Due to Sonatype/MavenCentral rate limiting, we temporarily disabled Bitrise Build Cache for Gradle plugins to prevent failing builds.
We're working on a fix to avoid the rate-limiting issue.
Posted 15 days ago. Jun 11, 2025 - 13:33 UTC

Identified

We have identified that builds with Gradle cache or Gradle analytics enabled (either manually or via the Bitrise step) are affected. Any other Android/Gradle builds are not affected. Thank you for your continued patience!
Posted 15 days ago. Jun 11, 2025 - 12:08 UTC

Investigating

We are currently investigating this issue.
Posted 15 days ago. Jun 11, 2025 - 11:23 UTC
This incident affected: Build Cache.