Experiencing increased queue times and build performance issues
Incident Report for Bitrise CI
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 13:19 UTC
Monitoring
A third party provider experienced degraded performance which as a result impacted our network performance as well. The issue has been resolved and performance degradation can be no longer observed on our end. The engineering team is continuing to monitor.
Posted Sep 22, 2022 - 22:36 UTC
Update
This incident was composed of a mix of two issues. The core issue still being investigated happens to be a networking issue spread across different stacks. Initially some stacks such as Xcode 14.0 and 14.1 experienced higher than average queues. Our team was able to resolve the high queue issue that was delaying build start. We thank you for your patience as we continue to work on the networking issue.
Posted Sep 22, 2022 - 20:31 UTC
Identified
We are currently experiencing higher-than-average queues on our Xcode 14.0 & 14.1. Our infra team is currently deploying additional resources to compensate and we are looking to also have positive improvements on the build performance across other stacks.
Posted Sep 22, 2022 - 17:40 UTC
Investigating
We are currently investigating this issue.
Posted Sep 22, 2022 - 16:16 UTC
This incident affected: Build Processing (OS X Stack (iOS)).