Slower response times on Bitrise web app and REST API

Incident Report for Bitrise

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 17:20 UTC

Identified

We are currently investigating slower response times on the Bitrise website at app.bitrise.io. Users may experience increased HTTP errors, intermittent page load failures, or timeouts when accessing the site.

Services impacted:
Website pages on app.bitrise.io, including sign-up and sign-in, and the Workflow Editor may return errors or fail to load.

Scope:
[All users]

Severity:
[SEV-1]

What we’re doing?

Our Engineering teams are actively investigating this incident and have identified the root cause. We will perform validated mitigations as soon as they are determined safe.

When will the next update be available?

You can expect a status update approximately 1 hour from now.
Posted Nov 25, 2025 - 16:55 UTC
This incident affected: ⚙️ Builds (CI).