ASDF Install Ruby faliures
Incident Report for Bitrise CI
Resolved
This issue currently only affects ruby 3.1, and 3.1.4 is preinstalled, so we advise users to default to these. We are working on a fix for the Ruby installation, which will be deployed in an upcoming stack update.
Posted Mar 01, 2024 - 15:07 UTC
Identified
This issue currently only affects ruby 3.1, and 3.1.4 is preinstalled, so we advise users to default to these. We are working on a fix for the Ruby installation, which will deploy in an upcoming stack update.
Posted Feb 29, 2024 - 10:19 UTC
Update
Our team has ensured that nothing has changed in our stacks and other internal components. We believe the issue to be an upstream issue in Ruby and ruby-build, but we are still investigating.

Here are two potential workarounds as of right now:
- Potential workaround 1: use one of the preinstalled Ruby versions: https://stacks.bitrise.io/tools/ruby/
- Potential workaround 2: Installing Ruby 3.3.0 works
Posted Feb 28, 2024 - 15:43 UTC
Update
We are continuing to investigate this issue.
Posted Feb 28, 2024 - 14:12 UTC
Investigating
We have examined the asdf install ruby command resulting in an error, we are looking into possible causes.
Posted Feb 28, 2024 - 14:12 UTC
This incident affected: Web App and Step Issue.