Long waiting times on Mac stacks due to degraded VM startup

Incident Report for Bitrise

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 11:14 UTC

Monitoring

We mitigated this incident and are currently monitoring our systems to resolve the elevated build queue times on Mac stacks.

Services:
Build start times and Mac stack queue wait times

Scope:
Builds on Mac stacks

Severity:
SEV-1

What we’re doing

Our Engineering teams released a fix to mitigate this incident and now actively monitoring our systems.

When will the next update be available?

You can expect a status update in 30 minutes.
Posted Nov 10, 2025 - 11:10 UTC
This incident affected: ⚙️ Builds (CI).