On April 28, 2026, rate limiting by Maven Central began causing 429 errors for Bitrise-hosted CI jobs attempting to download dependencies. We responded by enabling a proxy layer to mirror Maven packages within Bitrise in order to reduce load on Maven Central. The proxy service is working as intended, and the vast majority of dependency downloads over the previous 1.5 days have been served by Bitrise. There was, however, a subset of Bitrise CI jobs that were in the long tail and still experiencing 429 errors, even when following our recommended steps for using the mirror. Over the past several hours, we have evenly distributed traffic flow and have addressed the edge cases in customer Gradle configurations that bypassed the mirror.
If you are still experiencing 429 rate-limiting errors when installing dependencies, and you have already followed the recommended steps for using the mirror, please reach out to us at support@bitrise.io.
Posted Apr 29, 2026 - 20:24 UTC
Update
We are still taking additional measures and are observing decreasing instances of rate limiting
Services: Android Builds
Scope: A subset of users
Severity: SEV-2
What we’re doing:
Our Engineering teams released an update to mitigate this incident and are actively monitoring our systems.
When will the next update be available?
You can expect a status update approximately 2 hours from now.
Posted Apr 29, 2026 - 19:15 UTC
Update
We have taken additional measures and are observing decreasing instances of rate limiting
Services: Android Builds
Scope: A subset of users
Severity: SEV-2
What we’re doing:
Our Engineering teams released a fix to mitigate this incident and are actively monitoring our systems.
When will the next update be available?
You can expect a status update approximately 2 hours from now.
Posted Apr 29, 2026 - 16:50 UTC
Monitoring
We have released the step "activate-gradle-mirrors" so that our customers can enable the proxy without having to add the "install Android missing SDK components" step to their workflows. Please reach out to the Bitrise support team if you have any questions
Services: Android builds
Scope: [All users / a subset of users]
Severity: SEV-2
What we’re doing
Our Engineering teams released an update to mitigate this incident and now actively monitoring our systems.
When will the next update be available?
You can expect a status update approximately 1 hour from now.
Posted Apr 29, 2026 - 14:03 UTC
Identified
We are still seeing some Android build failures. We are creating a dedicated step just for enabling the proxy, so customers won't need to add the "install missing Android SDK components" step
Services impacted: Android builds
Scope: A subset of users
Severity: SEV-2
What we’re doing?
We are actively making adjustments to help resolve issues with the failing builds
When will the next update be available?
You can expect a status update approximately 1 hour from now.