Android - dependency download - 500 internal error issue - jcenter.bintray.com
Incident Report for Bitrise CI
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 22, 2017 - 13:07 UTC
Monitoring
We didn't see the error lately, still monitoring.
Posted over 1 year ago. Jun 22, 2017 - 10:30 UTC
Identified
jcenter.bintray.com has issues right now, similar to the previous ones (see e.g. http://status.bintray.com/incidents/v4ghm1s1xrp9).

The error looks like:

```
> Could not resolve org.apache.httpcomponents:httpclient:4.1.1.
> Could not get resource 'https://jcenter.bintray.com/org/apache/httpcomponents/httpclient/4.1.1/httpclient-4.1.1.pom'.
> Could not GET 'https://jcenter.bintray.com/org/apache/httpcomponents/httpclient/4.1.1/httpclient-4.1.1.pom'. Received status code 500 from server: Internal Server Error
```

A simple and reliable mitigation can be to configure a Bitrise Build Cache for your Android project, so that your dependencies are cached and doesn't have to be downloaded from bintray. You can find a guide for the setup at: https://discuss.bitrise.io/t/how-to-cache-gradle-dependencies/194
Posted over 1 year ago. Jun 22, 2017 - 09:34 UTC