Pipelines reporting success on partial rebuild if the failing stage contained an “aborted with success” workflow

Incident Report for Bitrise CI

Resolved

We have deployed a fix and verified that the issue is now resolved.
Posted Mar 02, 2023 - 08:25 UTC

Identified

We’ve identified that this only occurs when the rebuilt pipeline stage contained a workflow build having the status “aborted with success”. If a pipeline stage contains failed workflows and the rebuild fails, we report the status correctly.
We’re working towards the resolution.
Posted Mar 01, 2023 - 09:52 UTC

Investigating

We see build status reported to git providers (e.g. GitHub) as success for partially rebuilt pipelines if the rebuild fails.
Only pipelines are affected, standalone builds aren’t, and only when a partial rebuild gets triggered of an already run pipeline.
We are currently looking into the issue.
Posted Mar 01, 2023 - 09:10 UTC