Intermittent DNS failures

Incident Report for Bitrise

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 21:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 21:01 UTC

Update

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 20:21 UTC

Investigating

A subset of Bitrise builds are experiencing intermittent DNS failures.

Scope:
[A subset of users]

Severity:
[SEV-1]

What we’re doing?

Our Engineering teams are actively investigating this incident to identify the root cause. We’re checking recent deploys, logs, CDN, DNS health, and server availability. We will perform validated mitigations as soon as they are determined safe.

When will the next update be available?

You can expect a status update approximately 1 hour from now.
Posted Jul 08, 2026 - 20:19 UTC
This incident affected: ⚙️ Builds (CI).