Degraded performance in cache system

Incident Report for Bitrise CI

Postmortem

We encountered elevated latency issues between our Mac environment and the Central control plane. Fortunately, we had preemptively prepared for such scenarios with necessary updates already being tested in our staging environment and other clusters. Following the deployment of these changes to the Mac environment, the issue has been successfully resolved. We do not expect this issue to arise again and have not observed any serious impact on customer builds.

Posted May 09, 2024 - 16:08 UTC

Resolved

This incident has been resolved.
Posted May 09, 2024 - 15:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 09, 2024 - 15:26 UTC

Investigating

We are investigating issues with cache system. More updates to follow.
Posted May 09, 2024 - 15:10 UTC
This incident affected: Build Cache.